#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[^\n\r\w\W]*\/\/.*$)|(\/\/.*$)"
Local $sString = "t('bbbb',a,b,c)" & @CRLF & _
"t("aaaa")" & @CRLF & _
"t("aaaa')" & @CRLF & _
"t('aaaa') t('xxxx') // rrrr" & @CRLF & _
"t('bbbb',a,1)" & @CRLF & _
"// t('bbbb',{x:1,y:"(,)",z:[]},1)" & @CRLF & _
"t('中\n国')" & @CRLF & _
" //t(" fdgdfgfd df dfgdfgdf")" & @CRLF & _
"" & @CRLF & _
"fdff" & @CRLF & _
"" & @CRLF & _
"ddd //dddd" & @CRLF & _
" //This is a comment 1" & @CRLF & _
"" & @CRLF & _
"let a= 1" & @CRLF & _
"" & @CRLF & _
"// This is a comment 2" & @CRLF & _
"// This is a comment 3" & @CRLF & _
"function test(){" & @CRLF & _
" ... //This is a comment 3" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")