$re = '/(^[^\n\r\w\W]*\/\/.*$)|(\/\/.*$)/m';
$str = 't(\'bbbb\',a,b,c)
t("aaaa")
t("aaaa\')
t(\'aaaa\') t(\'xxxx\') // rrrr
t(\'bbbb\',a,1)
// t(\'bbbb\',{x:1,y:"(,)",z:[]},1)
t(\'中\\n国\')
//t(" fdgdfgfd df dfgdfgdf")
fdff
ddd //dddd
//This is a comment 1
let a= 1
// This is a comment 2
// This is a comment 3
function test(){
... //This is a comment 3
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);