import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^\\n\\r\\w\\W]*\\/\\/.*$)|(\\/\\/.*$)";
final String string = "t('bbbb',a,b,c)\n"
+ "t(\"aaaa\")\n"
+ "t(\"aaaa')\n"
+ "t('aaaa') t('xxxx') // rrrr\n"
+ "t('bbbb',a,1)\n"
+ "// t('bbbb',{x:1,y:\"(,)\",z:[]},1)\n"
+ "t('中\\n国')\n"
+ " //t(\" fdgdfgfd df dfgdfgdf\")\n\n"
+ "fdff\n\n"
+ "ddd //dddd\n"
+ " //This is a comment 1\n\n"
+ "let a= 1\n\n"
+ "// This is a comment 2\n"
+ "// This is a comment 3\n"
+ "function test(){\n"
+ " ... //This is a comment 3\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}