// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[^\n\r\w\W]*\/\/.*$)|(\/\/.*$)").unwrap();
let string = "t('bbbb',a,b,c)
t(\"aaaa\")
t(\"aaaa')
t('aaaa') t('xxxx') // rrrr
t('bbbb',a,1)
// t('bbbb',{x:1,y:\"(,)\",z:[]},1)
t('中\\n国')
//t(\" fdgdfgfd df dfgdfgdf\")
fdff
ddd //dddd
//This is a comment 1
let a= 1
// This is a comment 2
// This is a comment 3
function test(){
... //This is a comment 3
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}