# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^[^\n\r\w\W]*\/\/.*$)|(\/\/.*$)"
test_str = ("t('bbbb',a,b,c)\n"
"t(\"aaaa\")\n"
"t(\"aaaa')\n"
"t('aaaa') t('xxxx') // rrrr\n"
"t('bbbb',a,1)\n"
"// t('bbbb',{x:1,y:\"(,)\",z:[]},1)\n"
"t('中\\n国')\n"
" //t(\" fdgdfgfd df dfgdfgdf\")\n\n"
"fdff\n\n"
"ddd //dddd\n"
" //This is a comment 1\n\n"
"let a= 1\n\n"
"// This is a comment 2\n"
"// This is a comment 3\n"
"function test(){\n"
" ... //This is a comment 3\n"
"}\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.