using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^\n\r\w\W]*\/\/.*$)|(\/\/.*$)";
string input = @"t('bbbb',a,b,c)
t(""aaaa"")
t(""aaaa')
t('aaaa') t('xxxx') // rrrr
t('bbbb',a,1)
// t('bbbb',{x:1,y:""(,)"",z:[]},1)
t('中\n国')
//t("" fdgdfgfd df dfgdfgdf"")
fdff
ddd //dddd
//This is a comment 1
let a= 1
// This is a comment 2
// This is a comment 3
function test(){
... //This is a comment 3
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}