package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(id="page_([0-9]+)" +class=)"[^"]*">`)
var str = `<a id="page_123" class="garbage1"></a>some text<a id="page_124" class="garbage2"></a>`
var substitution = "\1"pagenum"> \2 "
fmt.Println(re.ReplaceAllString(str, substitution))
}