use strict;
my $str = '<a id="page_123" class="garbage1"></a>some text<a id="page_124" class="garbage2"></a>';
my $regex = qr/(id="page_([0-9]+)" +class=)"[^"]*">/mp;
my $subst = '\\1"pagenum"> \\2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";