// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(id="page_([0-9]+)" +class=)"[^"]*">"#).unwrap();
let string = "<a id=\"page_123\" class=\"garbage1\"></a>some text<a id=\"page_124\" class=\"garbage2\"></a>";
let substitution = "\\1\"pagenum\"> \\2 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}