re = /(id="page_([0-9]+)" +class=)"[^"]*">/m
str = '<a id="page_123" class="garbage1"></a>some text<a id="page_124" class="garbage2"></a>'
subst = '\\1"pagenum"> \\2 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result