const regex = /(id="page_([0-9]+)" +class=)"[^"]*">/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(id="page_([0-9]+)" +class=)"[^"]*">', 'gm')
const str = `<a id="page_123" class="garbage1"></a>some text<a id="page_124" class="garbage2"></a>`;
const subst = `\1"pagenum"> \2 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);