import re
regex = re.compile(r"(id=\"page_([0-9]+)\" +class=)\"[^\"]*\">", flags=re.MULTILINE)
test_str = "<a id=\"page_123\" class=\"garbage1\"></a>some text<a id=\"page_124\" class=\"garbage2\"></a>"
subst = "\\1\"pagenum\"> \\2 "
result = regex.sub(subst, test_str)
if result:
print(result)