using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http)s?:\/\/[^#?]+";
string input = @"https://url.spec.whatwg.org/#url-syntax
https://url.spec.whatwg.org/
https://www.google.com/search?q=Regular+Expressions&num=1000
https://www.google.com/search";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}