import Foundation
let pattern = ##"(http)s?:\/\/[^#?]+"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
https://url.spec.whatwg.org/#url-syntax
https://url.spec.whatwg.org/
https://www.google.com/search?q=Regular+Expressions&num=1000
https://www.google.com/search
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)