import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http)s?:\\/\\/[^#?]+";
final String string = "https://url.spec.whatwg.org/#url-syntax\n"
+ "https://url.spec.whatwg.org/\n"
+ "https://www.google.com/search?q=Regular+Expressions&num=1000\n"
+ "https://www.google.com/search";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}