re = /(http)s?:\/\/[^#?]+/
str = 'https://url.spec.whatwg.org/#url-syntax
https://url.spec.whatwg.org/
https://www.google.com/search?q=Regular+Expressions&num=1000
https://www.google.com/search'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end