package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http)s?:\/\/[^#?]+`)
var str = `https://url.spec.whatwg.org/#url-syntax
https://url.spec.whatwg.org/
https://www.google.com/search?q=Regular+Expressions&num=1000
https://www.google.com/search`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}