#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-9 ,]+|\"[а-яА-Я ,\n\r]+\", |\"[а-яА-Я ,\n\r]+\"$)+$"
Local $sString = ""Раз, два", 112, "Пять" & @CRLF & _
"Шесть", "авфывв"" & @CRLF & _
""Раз, два", "Три четыре", "Пять" & @CRLF & _
"Шесть"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")