re = /^(?:[0-9 ,]+|\"[а-яА-Я ,\n\r]+\", |\"[а-яА-Я ,\n\r]+\"$)+$/m
str = '"Раз, два", 112, "Пять
Шесть", "авфывв"
"Раз, два", "Три четыре", "Пять
Шесть"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end