import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9 ,]+|\\\"[а-яА-Я ,\\n\\r]+\\\", |\\\"[а-яА-Я ,\\n\\r]+\\\"$)+$";
final String string = "\"Раз, два\", 112, \"Пять\n"
+ "Шесть\", \"авфывв\"\n"
+ "\"Раз, два\", \"Три четыре\", \"Пять\n"
+ "Шесть\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}