package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[0-9 ,]+|\"[а-яА-Я ,\n\r]+\", |\"[а-яА-Я ,\n\r]+\"$)+$`)
var str = `"Раз, два", 112, "Пять
Шесть", "авфывв"
"Раз, два", "Три четыре", "Пять
Шесть"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}