$re = '/^(?:[0-9 ,]+|\"[а-яА-Я ,\n\r]+\", |\"[а-яА-Я ,\n\r]+\"$)+$/m';
$str = '"Раз, два", 112, "Пять
Шесть", "авфывв"
"Раз, два", "Три четыре", "Пят ь
Шесть"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);