using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0-9 ,]+|\""[а-яА-Я ,\n\r]+\"", |\""[а-яА-Я ,\n\r]+\""$)+$";
string input = @"""Раз, два"", 112, ""Пять
Шесть"", ""авфывв""
""Раз, два"", ""Три четыре"", ""Пять
Шесть""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}