#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){[^{}]+}"
Local $sString = "<svg width="500" height="100">" & @CRLF & _
" <text x="47.872" y="11.064" id="smartCar">{garage/temp} °C</text>" & @CRLF & _
" <circle id="circle1" cx="20" cy="20" r="10"" & @CRLF & _
" style="stroke: none; fill: #ff0000;"/>" & @CRLF & _
" <text x="47.872" y="11.064" id="smartCar">{home/sensors/temp/kitchen} °C</text>" & @CRLF & _
"</svg>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")