import re
regex = re.compile(r"{[^{}]+}", flags=re.MULTILINE)
test_str = ("<svg width=\"500\" height=\"100\">\n"
" <text x=\"47.872\" y=\"11.064\" id=\"smartCar\">{garage/temp} °C</text>\n"
" <circle id=\"circle1\" cx=\"20\" cy=\"20\" r=\"10\"\n"
" style=\"stroke: none; fill: #ff0000;\"/>\n"
" <text x=\"47.872\" y=\"11.064\" id=\"smartCar\">{home/sensors/temp/kitchen} °C</text>\n"
"</svg>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")