// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m){[^{}]+}").unwrap();
let string = "<svg width=\"500\" height=\"100\">
<text x=\"47.872\" y=\"11.064\" id=\"smartCar\">{garage/temp} °C</text>
<circle id=\"circle1\" cx=\"20\" cy=\"20\" r=\"10\"
style=\"stroke: none; fill: #ff0000;\"/>
<text x=\"47.872\" y=\"11.064\" id=\"smartCar\">{home/sensors/temp/kitchen} °C</text>
</svg>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}