import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^\\{\\}]+\\}";
final String string = "<svg width=\"500\" height=\"100\">\n"
+ " <text x=\"47.872\" y=\"11.064\" id=\"smartCar\">{garage/temp} °C</text>\n"
+ " <circle id=\"circle1\" cx=\"20\" cy=\"20\" r=\"10\"\n"
+ " style=\"stroke: none; fill: #ff0000;\"/>\n"
+ " <text x=\"47.872\" y=\"11.064\" id=\"smartCar\">{home/sensors/temp/kitchen} °C</text>\n"
+ "</svg>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}