package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){[^{}]+}`)
var str = `<svg width="500" height="100">
<text x="47.872" y="11.064" id="smartCar">{garage/temp} °C</text>
<circle id="circle1" cx="20" cy="20" r="10"
style="stroke: none; fill: #ff0000;"/>
<text x="47.872" y="11.064" id="smartCar">{home/sensors/temp/kitchen} °C</text>
</svg>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}