using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{[^{}]+}";
string input = @"<svg width=""500"" height=""100"">
<text x=""47.872"" y=""11.064"" id=""smartCar"">{garage/temp} °C</text>
<circle id=""circle1"" cx=""20"" cy=""20"" r=""10""
style=""stroke: none; fill: #ff0000;""/>
<text x=""47.872"" y=""11.064"" id=""smartCar"">{home/sensors/temp/kitchen} °C</text>
</svg>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}