using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\W_](?:[\w.-]*[^\W_])?@[^\W_](?:\w*[^\W_])?(?:[.-]\w*[^\W_])*\.[^\W_]{2,}$";
string input = @"jasmin.martinez@tester.co.rolisa-brown.king@tester.co.ro
jasmin-martinez@tester.co
lisabrown.king@tester.co
jasmin-martinez@teste-r.co
j@teste-r.co";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}