// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\W_](?:[\w.-]*[^\W_])?@[^\W_](?:\w*[^\W_])?(?:[.-]\w*[^\W_])*\.[^\W_]{2,}$").unwrap();
let string = "jasmin.martinez@tester.co.rolisa-brown.king@tester.co.ro
jasmin-martinez@tester.co
lisabrown.king@tester.co
jasmin-martinez@teste-r.co
j@teste-r.co";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}