re = /^[^\W_](?:[\w.-]*[^\W_])?@[^\W_](?:\w*[^\W_])?(?:[.-]\w*[^\W_])*\.[^\W_]{2,}$/m
str = 'jasmin.martinez@tester.co.rolisa-brown.king@tester.co.ro
jasmin-martinez@tester.co
lisabrown.king@tester.co
jasmin-martinez@teste-r.co
j@teste-r.co'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end