$re = '/^[^\W_](?:[\w.-]*[^\W_])?@[^\W_](?:\w*[^\W_])?(?:[.-]\w*[^\W_])*\.[^\W_]{2,}$/m';
$str = 'jasmin.martinez@tester.co.rolisa-brown.king@tester.co.ro
jasmin-martinez@tester.co
lisabrown.king@tester.co
jasmin-martinez@teste-r.co
j@teste-r.co';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);