use strict;
my $str = 'jasmin.martinez@tester.co.rolisa-brown.king@tester.co.ro
jasmin-martinez@tester.co
lisabrown.king@tester.co
jasmin-martinez@teste-r.co
j@teste-r.co';
my $regex = qr/^[^\W_](?:[\w.-]*[^\W_])?@[^\W_](?:\w*[^\W_])?(?:[.-]\w*[^\W_])*\.[^\W_]{2,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}