# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/TRACE\([&](\w+)(\s*)[,](\s*)(\w+)(\s*)[,](\s*)(\w+)(\s*)[,]/TRACE\(/gm;t' <<< "TRACE(&logger_mr , DEBUG_2, NULL,UdpPathMgmtLogger::entranceStr_sc);
TRACE(&logger_mr,DEBUG_2, NULL,
UdpPathMgmtLogger::entranceStr_sc);
TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;"