$re = '/TRACE\([&](\w+)(\s*)[,](\s*)(\w+)(\s*)[,](\s*)(\w+)(\s*)[,]/m';
$str = 'TRACE(&logger_mr , DEBUG_2, NULL,UdpPathMgmtLogger::entranceStr_sc);
TRACE(&logger_mr,DEBUG_2, NULL,
UdpPathMgmtLogger::entranceStr_sc);
TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;';
$subst = "TRACE\(";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;