import Foundation
let pattern = #"TRACE\([&](\w+)(\s*)[,](\s*)(\w+)(\s*)[,](\s*)(\w+)(\s*)[,]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
TRACE(&logger_mr , DEBUG_2, NULL,UdpPathMgmtLogger::entranceStr_sc);
TRACE(&logger_mr,DEBUG_2, NULL,
UdpPathMgmtLogger::entranceStr_sc);
TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"TRACE\("#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)