#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)TRACE\([&](\w+)(\s*)[,](\s*)(\w+)(\s*)[,](\s*)(\w+)(\s*)[,]"
Local $sString = "TRACE(&logger_mr , DEBUG_2, NULL,UdpPathMgmtLogger::entranceStr_sc);" & @CRLF & _
"TRACE(&logger_mr,DEBUG_2, NULL," & @CRLF & _
" UdpPathMgmtLogger::entranceStr_sc);" & @CRLF & _
"" & @CRLF & _
"TRACE(&logger_mr , DEBUG_2 , NULL ," & @CRLF & _
" UdpPathMgmtLogger::entranceStr_sc;"
Local $sSubst = "TRACE\("
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)