using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\.(\d+)\.(\d+)\s+(\d+):(\d+)";
string input = @" Datentr„ger in Laufwerk H: ist Backup
Volumeseriennummer: 5D78-6EC0
Verzeichnis von H:\_Chaos\Zips
14.05.2019 21:31 2 758 test.rpp
1 Datei(en), 2 758 Bytes
0 Verzeichnis(se), 20 214 288 384 Bytes frei";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}