import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\.(\\d+)\\.(\\d+)\\s+(\\d+):(\\d+)";
final String string = " Datentr„ger in Laufwerk H: ist Backup\n"
+ " Volumeseriennummer: 5D78-6EC0\n\n"
+ " Verzeichnis von H:\\_Chaos\\Zips\n\n"
+ "14.05.2019 21:31 2 758 test.rpp\n"
+ " 1 Datei(en), 2 758 Bytes\n"
+ " 0 Verzeichnis(se), 20 214 288 384 Bytes frei";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}