import Foundation
let pattern = #"(\d+)\.(\d+)\.(\d+)\s+(\d+):(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Datentr„ger in Laufwerk H: ist Backup
Volumeseriennummer: 5D78-6EC0
Verzeichnis von H:\_Chaos\Zips
14.05.2019 21:31 2 758 test.rpp
1 Datei(en), 2 758 Bytes
0 Verzeichnis(se), 20 214 288 384 Bytes frei
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)