re = /(\d+)\.(\d+)\.(\d+)\s+(\d+):(\d+)/m
str = ' Datentr„ger in Laufwerk H: ist Backup
Volumeseriennummer: 5D78-6EC0
Verzeichnis von H:\\_Chaos\\Zips
14.05.2019 21:31 2 758 test.rpp
1 Datei(en), 2 758 Bytes
0 Verzeichnis(se), 20 214 288 384 Bytes frei'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end