const regex = /(\d+)\.(\d+)\.(\d+)\s+(\d+):(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\.(\\d+)\\.(\\d+)\\s+(\\d+):(\\d+)', 'gm')
const str = ` Datentr„ger in Laufwerk H: ist Backup
Volumeseriennummer: 5D78-6EC0
Verzeichnis von H:\\_Chaos\\Zips
14.05.2019 21:31 2 758 test.rpp
1 Datei(en), 2 758 Bytes
0 Verzeichnis(se), 20 214 288 384 Bytes frei`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}