import re
regex = re.compile(r"(\d+)\.(\d+)\.(\d+)\s+(\d+):(\d+)", flags=re.MULTILINE)
test_str = (" Datentr„ger in Laufwerk H: ist Backup\n"
" Volumeseriennummer: 5D78-6EC0\n\n"
" Verzeichnis von H:\\_Chaos\\Zips\n\n"
"14.05.2019 21:31 2 758 test.rpp\n"
" 1 Datei(en), 2 758 Bytes\n"
" 0 Verzeichnis(se), 20 214 288 384 Bytes frei")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")