#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\{\s*method: ?["'](\w+)["']\s*\};"
Local $sString = " { method: "GET" };"
Local $sSubst = "{method: "$1", credentials: "same-origin"};"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)