re = /\{\s*method: ?["'](\w+)["']\s*\};/
str = ' { method: "GET" };'
subst = '{method: "$1", credentials: "same-origin"};'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result