const regex = /\{\s*method: ?["'](\w+)["']\s*\};/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\s*method: ?["\'](\\w+)["\']\\s*\\};', 'g')
const str = ` { method: "GET" };`;
const subst = `{method: "$1", credentials: "same-origin"};`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);