// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\{\s*method: ?["'](\w+)["']\s*\};"#).unwrap();
let string = " { method: \"GET\" };";
let substitution = "{method: \"$1\", credentials: \"same-origin\"};";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}