#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(^\\\\host1\\teams\\)(?P<Team>[^\\]+)"
Local $sString = "\\host1\teams\team1\bla\bla\bla" & @CRLF & _
"\\host1\teams\team2\bla\bla" & @CRLF & _
"\\host1\teams\team3\bla" & @CRLF & _
"\\host1\teams\team4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")