const regex = /(^\\\\host1\\teams\\)(?P<Team>[^\\]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\\\\\\\host1\\\\teams\\\\)(?P<Team>[^\\\\]+)', 'gmi')
const str = `\\\\host1\\teams\\team1\\bla\\bla\\bla
\\\\host1\\teams\\team2\\bla\\bla
\\\\host1\\teams\\team3\\bla
\\\\host1\\teams\\team4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}